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Resumo: A micromorfologia é uma técnica que tradicionalmente vem sendo utilizada de forma 

qualitativa no estudo da gênese do solo e na avaliação e no monitoramento de diversas práticas 

agrícolas. Com o auxílio das técnicas de processamento e análise digital de imagem, a micromorfologia 

é capaz de fornecer resultados quantitativos de macroporosidade e composição, além de possibilitar 

a visualização das alterações estruturais causadas pelo uso do solo. Este trabalho teve por objetivo 

avaliar um método de análise de imagens e quantificação da macroporosidade utilizando os softwares 

gratuitos ImageJ e Hypercube. Os resultados mostraram que o procedimento é simples e rápido e 

produz resultados compatíveis com os dados obtidos por métodos convencionais. 

Termos de indexação: micromorfologia; estrutura de solos; porosidade. 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

22



 

 

      Método para estimativa de macroporosidade em lâminas delgadas de solos por meio de análise de imagens. 

 

                                                                                                   2 

INTRODUÇÃO 

A micromorfologia tem sido, há décadas, importante ferramenta para o estudo de solos. Embora 

inicialmente de caráter basicamente descritivo e qualitativo, a disponibilidade de ferramentas e 

programas computacionais para análise e quantificação em imagens tem proporcionado a evolução 

para uma abordagem mais quantitativa. No entanto, dada a complexidade do meio em estudo e sua 

natural heterogeneidade, os procedimentos necessitam um contínuo desenvolvimento e adaptação, 

para que resultados reprodutíveis e acurados sejam obtidos. Outra demanda é a automação dos 

procedimentos para ganho de produtividade, em função do tempo necessário para separação de 

feições de interesse, quando se usam procedimentos totalmente manuais. Vários detalhes e 

peculiaridades dos métodos também precisam ser adequadamente entendidos, para se evitar o uso 

inadequado destas ferramentas.  

A avaliação da estrutura do solo é necessária para um entendimento completo da morfologia dos 

solos, e requer o uso de diversas técnicas, incluindo a análise micromorfológica. Essa técnica tem sido 

aplicada em vários trabalhos sobre a gênese do solo e na avaliação de efeitos de manejo e de práticas 

agrícolas nas propriedades físicas do solo (Castro et al., 2003). As técnicas de processamento e análise 

digital de imagem aplicadas à micromorfologia permitem gerar resultados quantitativos de alguns 

atributos, e também a visualização dos impactos na estrutura causados pela compactação e pelo 

adensamento (Castro et al., 2003; Clemente et al., 2005). É possível seu uso para a avaliação 

quantitativa da dinâmica estrutural em amostras indeformadas (Viana et al., 2004). O preparo das 

lâminas deve seguir os protocolos já desenvolvidos e que permitem manter a estrutura original do 

solo (Cooper et al. 2017). 

A análise de imagens permite mensurar feições morfológicas que podem auxiliar a interpretação do 

comportamento físico da amostra. A análise geralmente é feita a partir de imagens digitais obtidas por 

sensores acoplados a microscópios, lupas ou scanners de mesa. As imagens devem ser processadas 

por softwares adequados, e quantificadas com base em parâmetros morfológicos já reconhecidos e 

descritos na literatura. Existe hoje a opção de programas gratuitos, disponíveis na internet e já 

reconhecidos e usados amplamente na comunidade científica para a análise e mensuração de imagens 

digitais, destacando-se o ImageJ 1.47t (Ferreira e Rasband, 2012), que, além dessas características, 

permite também o desenvolvimento de rotinas para outras medidas específicas através de pluggins. 

Este trabalho visa estabelecer procedimentos para quantificação da porosidade em lâminas delgadas 

de solo, a partir de imagens obtidas por microscopia ótica convencional, com o uso de programas 
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científicos gratuitos de análise e tratamento de imagens disponíveis na Internet. O método visa auxiliar 

os procedimentos de análise e interpretação micromorfológica de lâminas delgadas, possibilitando a 

quantificação de regiões homogêneas por meio de algoritmos de classificação (semi) automática. 

Desta forma, à interpretação puramente qualitativa pode ser agregada a análise quantitativa de 

feições de interesse, e a extrapolação para volumes das áreas pode ser possível quando as condições 

de estereologia forem atendidas. Os procedimentos são descritos de forma a padronizar e permitir 

maior reprodutibilidade de resultados. 

MATERIAL E MÉTODOS 

DESCRIÇÃO DO MÉTODO DA QUANTIFICAÇÃO DE POROS 

O método foi desenvolvido para quantificação de regiões com características homogêneas e 

claramente discerníveis em imagens de lâminas delgadas para micromorfologia de solos, obtidas por 

meio de câmeras acopladas a microscópios óticos ou lupas binoculares, ou por meio de scanners de 

alta resolução. De forma resumida, inicialmente são aplicados tratamentos à imagem digital para 

redução de ruídos e realce de cores. Seguem-se a separação e quantificação de zonas similares da 

imagem por meio de algoritmo de classificação supervisionada. Esta classificação é interpretada por 

inspeção e comparação com a imagem original, e os valores de área para cada região homogênea são 

tabelados e computados. 

No caso da porosidade em amostras de solos, a utilização de um corante na resina de impregnação 

para melhorar o contraste facilita a separação correta de áreas de poros e a correta interpretação de 

feições. Inicialmente são tomadas as imagens digitais e transferidas para computador. Recomenda-se 

que as imagens sejam gravadas e processadas em formatos de arquivo de imagem não comprimidos, 

como o TIFF. A imagem a ser processada deve então ser aberta e trabalhada no programa ImageJ 

(Abramoff et al., 2004; Schneider et al., 2012; Rasbane, 2014). 

Recomenda-se cortar as bordas da imagem para excluir das análises as partes da lâmina sem material 

ou com material muito fino, trabalhando- se apenas na parte central da imagem salvando-se como 

uma nova imagem TIF. Nesta nova imagem serão então feitos os demais procedimentos. Aplica-se o 

filtro de mediana para redução de ruído: Process>Filters>Median... (Radius=2.0). 

Procede-se ao ajuste de brilho e contraste (por ajuste visual): Image>Adjust>Brightness/contrast 

Salva-se a imagem gerada com novo nome. O procedimento de separação e quantificação da 

porosidade (ou outra feição de interesse) é feito usando-se o programa Hypercube (Pazak, 2015; 
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http://www.erdc.usace.army.mil/Media/FactSheets/FactSheetArticleView/tabid/9254/Article/47668

1/hy percube.aspx). Abre-se a imagem no programa Hypercube. File>Open...>Load TIFF data 

Converte-se a imagem para o “cubo”: Image>Convert image>Color to cube>BRG Cube Nesta nova 

“imagem” com a extensão cube, procedesse à classificação: Function>Classify>Color to cube>BRG 

Cube Na caixa de opções (pop-up) assinalar o método “k-means”: Method>K means Clicar o botão de 

“options” e colocar o número de classes (a depender da análise, geralmente de 10 a 30): Number of 

classes>24 Clicar o botão de “Classify” e aguardar o processamento. Ao término do processamento, 

colocar a imagem em sua última camada usando os botões no canto superior esquerdo e converter 

para uma nova imagem TIF, salvando-a em seguida:Image>Convertimage>Color toindexed>256. 

Gerar a tabela com as classes: Function>Plot>Histogram>Window (class map) Salvar a tabela do class 

map: File>Save Analisar na imagem classificada (”cube”), correndo o mouse sobre a mesma, 

identificando o número da classe que corresponde ao atributo de interesse, anotando o mesmo. Este 

número, que aparece quando o mouse está sobre o campo, é o mesmo da tabela “class map”, já salva, 

que poderá ser editada em planilha.  

APLICAÇÃO 

Os procedimentos descritos foram aplicados a um conjunto de lâminas delgadas, proveniente dos 

perfis de solos amostrados na comunidade de Faraó em Cachoeiras de Macacu/RJ (Quadro 1). 
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 Quadro 1 – Caracterização dos solos estudados 

Perfil Classificação Uso Altitude (m) Relevo Situação 

P1 CAMBISSOLO HÁPLICO 
Distrófico típico, textura 
argilosa pouco cascalhenta, A 
moderado  

Banana 68 Ondulado Declivoso 

P2 CAMBISSOLO HÁPLICO 
Distrófico típico, textura média 
pouco cascalhenta, A 
moderado 

Banana 228 Ondulado Terço 
médio 

P3 LATOSSOLO VERMELHO 
Eutrófico típico, textura 
argilosa, A moderado 

Pupunha 214 Montanhoso Terço 
médio 

P4 CAMBISSOLO FLÚVICO Tb 
distrófico gleissólico, textura 
argilosa, A moderado 

Banana 48 Suave 
ondulado 

Área plana 
de terraço 
fluvial 

P5 LATOSSOLO AMARELO 
Distrófico típico, textura 
argilosa, A moderado, 
epieutrófico 

Pastagem 59 Forte ondulado Terço 
médio 

P6 CAMBISSOLO HÁPLICO tb 
Distrófico típico, textura 
argilosa, A moderado 

Banana/florest
a 

303 Forte ondulado Terço 
médio 

P7 LATOSSOLO AMARELO 
Distrófico típico, textura 
argilosa, A moderado 

Mandioca 70 Suave 
ondulado 

Terço 
médio 

P8 CAMBISSOLO HÁPLICO tb 
Distrófico típico, textura média, 
A moderado, epieutrófico 

Banana 159 Ondulado Terço 
médio 

P9 LATOSSOLO VERMELHO 

Distrófico típico, textura 

argilosa, A moderado 

Banana 419 Montanhoso Terço 

médio 

 

Estes perfis são provenientes de oito propriedades rurais, as quais representavam as diferentes cotas 

de relevo da comunidade e que apresentavam diferentes sistemas de produção, se destacando o 

cultivo de banana, aipim, pupunha e pasto. Os perfis estudados estão inseridos em diferentes 

propriedades rurais, as quais apresentam revelo bastante distinto. Os solos foram classificados como 

Latossolos e Cambissolos, sendo que em todas as propriedades que tiveram os solos classificados 

como Cambissolos, a banana é o principal componente do sistema produtivo. Já nos Latossolos, a 

produção é mais diversificada, com pastagem, pupunha e mandioca. 

Em cada propriedade foi aberta uma trincheira para descrição e coleta de um perfil de solo. Para a 

coleta das amostras a serem analisadas micromorfologicamente, coletou-se uma amostra 

indeformada, na profundidade de 10 a 20 cm do perfil de solo amostrado e confeccionadas lâminas 

delgadas de 2,5 x 1 cm (Figura 1). 
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Figura 1 – Imagens obtidas de lâminas delgadas em scanner V700 Photo, na resolução de 3600 dpi. 

Cada amostra foi processada nos programas acima descritos gerando a sequência de transformação 

da imagem (Figura 2). 
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Figura 2 - Sequência de aplicação a lamina delgada de solo. a) Imagem inicial da lâmina; b) recorte 

tratado por filtragem e realce; c) imagem classificada; d) porosidade medida, em preto. 

RESULTADOS E DISCUSSÃO 

Foi possível separar a porosidade visível de forma rápida e sem necessidade de ajustes manuais pelo 

uso dos procedimentos descritos, de forma semi-automática. Os resultados obtidos (Quadro 2) 

indicam que a macroporosidade, medida por este método, foi afetada pelo uso do solo. O perfil 5, o 

único com pastagem, apresentou a menor porosidade. A maior porosidade foi a do perfil 2, um 

Cambissolo com produção de banana. Nos demais perfis a macroporosidade é bastante semelhante. 

Os valores absolutos de porosidade passíveis de medida por este método são limitados pela resolução 

da imagem, daí a comparação com outros métodos, como os resultados da mesa de tensão, vão 

depender da magnificação e do tamanho da área medida, o que não limita o potencial para seu uso. 

Esses resultados auxiliaram o estudo do diagnóstico do solo feito nessa comunidade, permitindo uma 

melhor caracterização da porosidade do solo e consequentemente entender o fluxo de infiltração de 

água nessas propriedades, colaborando com o trabalho realizado por Clemente et al. (2017) sobre 

erodibilidade dos solos nessas áreas. Todas as informações auxiliaram as tomadas de  decisão quanto 

a práticas de técnicas conservacionistas sugeridas para um manejo mais adequado para estas áreas, 

como podem ser vistas em Martins et al. (2014).    

28



 

 

      Método para estimativa de macroporosidade em lâminas delgadas de solos por meio de análise de imagens. 

 

                                                                                                   8 

Quadro 2 – Macroporosidade avaliada pela análise de imagem nos perfis. 

Perfil Classificação Porosidade 
total 

Macroporosi
dade 

Densidade do 
solo 

(g/cm3) 

Densidade do 
solo 

(g/cm3) 
P1 CAMBISSOLO HÁPLICO 

Distrófico típico, textura 
argilosa pouco 
cascalhenta, A moderado  

48,78 17 1,26 2,46 

P2 CAMBISSOLO HÁPLICO 
Distrófico típico, textura 
média pouco cascalhenta, 
A moderado 

61,07 27 0,95 2,44 

P3 LATOSSOLO VERMELHO 
Eutrófico típico, textura 
argilosa, A moderado 

57,44 15 1,03 2,42 

P4 CAMBISSOLO FLÚVICO 
Tb distrófico gleissólico, 
textura argilosa, A 
moderado 

49,03 13 1,03 2,59 

P5 LATOSSOLO AMARELO 
Distrófico típico, textura 
argilosa, A moderado, 
epieutrófico 

38,89 12 1,54 2,52 

P6 CAMBISSOLO HÁPLICO tb 
Distrófico típico, textura 
argilosa, A moderado 

52,65 17 1,16 2,45 

P7 LATOSSOLO AMARELO 
Distrófico típico, textura 
argilosa, A moderado 

49,61 16 1,28 2,54 

P8 CAMBISSOLO HÁPLICO tb 
Distrófico típico, textura 
média, A moderado, 
epieutrófico 

57,79 11 1,03 2,44 

P9 LATOSSOLO VERMELHO 
Distrófico típico, textura 
argilosa, A moderado 

43,20 12 1,17 2,50 

CONCLUSÕES 

Foi possível obter a medida da macroporosidade de forma semi-automática e com procedimentos 

rápidos e padronizados. Os resultados indicam que o método apresenta potencial para aplicação em 

estudos de avaliação de uso do solo, mas é limitado pela resolução da imagem utilizada. 
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